zondag, februari 24, 2008

HTTP websites werken niet, HTTPS websites doen het wel?!

Onlangs ondervond één van mijn collega's het volgende probleem"

Geen enkele website was meer toegankelijk via zijn computer. Het maakte niet uit welke browser hij gebruikte: zowel via Internet Explorer als via FireFox was het niet meer mogelijk om het internet te browsen.

Zelfs telnetten naar poort 80 lukte niet, er werd geen verbinding gelegd. Het telnetten naar andere poorten, bijvoorbeeld op poort 25 naar een SMTP(email)-server werkte prima.

Maar vreemd genoegd:

Was het browsen naar beveiligde websites (met https:// ervoor) geen enkel probleem. Die functioneerden allemaal prima. En ook de websites die hij als ontwikkelaar op zijn lokale machine draaide waren (via het http protocol) gewoon toegankelijk via alle browsers.

Wat bleek nu de oorzaak te zijn: hij had gebruik gemaakt van een Cisco VPN client die hij later weer gedeinstalleeerd had. Daarbij was de device driver vsdatant.sys achtergebleven die het probleem bleek te veroorzaken.

De oplossing:

Het uitschakelen van die devicedriver door het aanpassen van de volgende registerwaarde:

1) Ga naar: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\vsdatant
2) Selecteer de Start parameter en verander de waarde in: 3
3) Start de machine opnieuw op

Overigens: deze oplossing heeft mij vijf chocoladeletters van een blije collega opgeleverd :)

1 opmerking:

Anoniem zei

Geweldige tip. De wijziging moet in de veilige modus plaats vinden.

Joop

Gerelateerde berichten